+2
Fixed

Unchecky service causes WMI provider host to constantly run.

Anonymous 6 years ago updated by Rubymaryum 2 years ago 6
I installed unchecky a little while ago, and recently started noticing that the WMI provider host service was constantly running, sapping CPU and interrupting audio from itunes (a known concequence of WMI provider host running).

After doing a set of clean boots (as specified in http://support.microsoft.com/kb/929135) and isolating services, it turned out that the unchecky service was causing this. Disabling the service fixed the issue.

System-wise I am running Windows 8.1 64-bit on an intel i5 4670k. 8GB RAM and booting the OS off a 240GB SSD. (more details can be provided if necessary)

Answer

Answer
Fixed
The issue should be fixed in Unchecky v0.3.7
I had the same problem... wmiprvse.exe was constantly using 1-3% of the cpu... not a big thing, but it was preventing my cpu from going to the lowest frequency and thus it was reducing battery life... uninstalled unchecky (for now), waiting to see if the bug can be resolved.
Same here. It's easy to check that unchecky_svc is the culprit: stop Windows Management Instrumentation service and unchecky_svc goes from 0% usage to whopping 45% on my system. Maybe I just missed this, but older versions didn't force WMI to constantly hog CPU, right?
Same issue here on Windows 8.1 x64, WMI process would constantly consume anywhere between 2-13% CPU (Celeron 1007U 1.5Ghz.) Disabled all non-Microsoft services, rebooted, noted that WMI was not using any CPU cycles, then re-enabled the non-MS services in batches, eventually found that only Unchecky is causing this behavior.
Under review
Hi,
Thanks for this feedback.
We will look into this and get back to you here with an answer.

Thanks,
Hi, can absolutely confirm this on Win 8.1 Pro 32 bit. Took me ages to work out what it was, as I only found that wmiprvse.exe no longer used up to 7% CPU after uninstalling unchecky AND a restart.

Conversely, having gone back to an earlier disk image, with Unchecky running, wmiprvse.exe was not evident. However, I was offered 1 windows update: KB2919355. Once I had installed that, wmiprvse.exe started using 3-7% CPU again. Uninstalling Unchecky and restarting again solved the problem with wmiprvse.exe CPU use.

Answer
Fixed
The issue should be fixed in Unchecky v0.3.7