0
Fixed

Unchecky 2.1.6 on Windows XP Service Error

MrWolf-to 6 years ago updated 6 years ago 11
Hi!
I've just upgrade to Unchecky 2.1.6: on Windows XP, I always get a Service error message.

Answer

Answer
Fixed
Should be fixed in v0.3.2.
Under review
Hi,
Could you please provide the exact error message, and/or a screenshot of the error?
I get this message (in Italian):


which says that an error occurred in Unchechy Service and that the application will be closed.
If I click on more information, I get this:

Hope it's clear.
Thanks.
+1
Thanks. That's what I meant, but unfortunately those screenshots don't provide enough information about the failure.
Could you please send me a crash dump?
You can use the ProcDump utility:
http://technet.microsoft.com/en-us/sysinternals/dd996900.aspx

Launching procdump unchecky_svc should do the job.
Ok, sorry, for the late delay, now I've found the time try.
Here's the dump file: http://www.tusfiles.net/73crjdefkdu1
Thanks
+1
Unfortunately this crash dump doesn't contain the relevant information.
Please try the following:
  • Wait until you see the crash message.
  • Run procdump -mp -e unchecky_svc.exe.
  • Click on "Debug" on the crash message.
Thanks, and sorry for not getting it right the first time.
Ok, tried again. Hope this times works. ;)
http://www.tusfiles.net/mp3wck7uyirz
Don't worry, thanks to you for helping.
P.S. I've just tried in another computer of mine and this time I'm getting one of those "the memory cannot be written errors". :/
Yes, that's what I need :)
Please try the following version, which should fix the issue:
https://www.dropbox.com/s/oqdd6p17gfx8pum/unchecky...

If all works well, I'll release a new version with the fix.
Ok, I've just tried and it doesn't me any problem. :)
Can you tell me if it's something related to my configuration? Because I tried with a fresh intallation of Windows XP (on a virtual machine) and that version 2.1.6 didn't give me any problem.
Many thanks again!
Great :)
The bug was related to networking. When did you see the error message?
I could eventually reproduce it by launching, and then shutting down the service.
Answer
Fixed
Should be fixed in v0.3.2.
Hi! Well, the bug appeared just when I installed 2.1.6 and every time I re-installed it.
Now, it works well. :)
Thanks again!