+3
Fixed

Unchecky 0.3.7.5 Setup crashes on XP computer with non-SSE2 CPU

Anonymous 5 years ago updated by Unchecky 5 years ago 4
Attempting to install Unchecky 0.3.7.5 on Windows XP, with a non-SSE2 CPU (a CPU that does not support the SSE2 instruction set, specifically an AMD Sempron 2800+ from early 2005) crashes with the following error message:

"Unchecky Setup has encountered a problem and needs to close. We are sorry for the inconvenience."



Then after I close that window I get another window with the following error message:

"HRESULT 0xc000001d"



This is probably a bug caused by requiring SSE2 instructions. I've noticed lately more and more programs crash on this computer with similar bugs (for instance, uTorrent version 3.4.x requires SSE2 whereas uTorrent 3.3.x and earlier work fine on this computer). You should change your compilation settings to produce executables that don't require the SSE2 instruction set... I am guessing you are using Microsoft Visual Studio 2012 or later compilers, because it is the 2012 and later Microsoft compilers that have requiring SSE2 instructions as the default, whereas earlier Microsoft compilers just required i686/Pentium Pro (Pentium + MMX) by default, and GCC still only requires a 386 by default. Almost all software that is now suddenly requiring SSE2 instructions and crashing on non-SSE2 CPUs is software that recently migrated to Microsoft Visual Studio 2012 or later, which I am guessing you did with Unchecky in between versions 0.3.7 and 0.3.7.5.

I would suggest using the "/arch:IA32" option as described here:
https://msdn.microsoft.com/en-us/library/7t5yh4fd%28v=vs.110%29.aspx

Also, this bug did not exist in version 0.3.7 or earlier of Unchecky, which worked fine.

Answer

Answer
Started
Thank you for the report. The issue should be fixed in the next version of Unchecky.
Answer
Started
Thank you for the report. The issue should be fixed in the next version of Unchecky.
Now I'm waiting the next version of unchecky!!!!!
This was fixed in the latest version. 0.3.8 is now available on the web site. Please let us know if the problem still exists.